Some registration tokens may not be valid when expected to be.
Incident Report for Med+Proctor
Resolved
This incident has been resolved.
Posted Mar 20, 2018 - 19:03 UTC
Identified
Student users should contact support help@medproctor.com
Posted Mar 20, 2018 - 15:56 UTC