networking issue from 3rd party service provider

Incident Report for MedProctor

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 23:05 UTC

Monitoring

A work around for the 3rd party networking issue has been implemented. This service is being monitored
Posted Oct 29, 2025 - 18:29 UTC

Identified

www.medproctor.com is unavailable due to a networking issue at a 3rd party service provider. Please visit https://secure.medproctor.com to access the MedProctor application.
Posted Oct 29, 2025 - 18:18 UTC
This incident affected: www marketing and link redirect site.