secure.medproctor.com performance degraded

Incident Report for MedProctor

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 21:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2026 - 19:16 UTC

Identified

Performance of secure.medproctor.com has degraded. Users may experience longer than usual wait times during loads. A fix is being implemented.
Posted Jun 01, 2026 - 16:45 UTC
This incident affected: secure.medproctor.com Student Portal and secure.medproctor.com Admin Portal.