help.medproctor.com software updates

Incident Report for MedProctor

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 00:46 UTC

Identified

We are updating help.medproctor.com presently. Contact help@medproctor.com by email for assistance.
Posted Mar 11, 2026 - 00:29 UTC
This incident affected: help.medproctor.com.