Authentication services update
Incident Report for Med+Proctor
Resolved
This update has finished successfully.
Posted Jul 17, 2018 - 01:20 UTC
Investigating
Authentication services at Med+Proctor are currently unavailable for a planned service outage until 0129 UTC
Posted Jul 17, 2018 - 01:18 UTC
This incident affected: secure.medproctor.com Student Portal and secure.medproctor.com Admin Portal.